≡ Menu

Piwik Upgrade from 2.2.2 to 2.4.0 Errors

Piwik Upgrade 2.4.0 ErrorsI have been holding off to upgrade the existing Piwik installation since Piwik 2.2.2. The reason being I always encounter errors when tried to upgrade automatically. As such I have to backup the entire website and the database, doing troubleshooting and fixing ptoblems, and all these tasks take a significant amount of time.

However, Piwik released version 2.4.0 a few days ago and this makes my installation 2 generations old. So I decided to upgrade to current version for the sake of better security.

Here’s how I fixed the problems encountered when upgrading from Piwik 2.2.2 to Piwik 2.4.0.

Plugins

Disable and uninstall all third party plugins. Disable core plugins that I am not using.

I found the ZenMode plugin in my Piwik 2.2.2. It was disabled and uninstalled prior to the upgrading to 2.4.0. (In 2.4.0, ZenMode plugin is part fo the core)

Still I got some HTML access errors. And here’s one of them:

“Failed to load HTML file”

Setting Folder Permission to 755

I found partial answer to my problem at http://forum.piwik.org. Apparently, when upgrading from 2.2.2 to Piwik 2.3.0, you’ll have to set the following folders’ permission to 755:

plugins/ZenMode/
plugins/ZenMode/angularjs/
plugins/ZenMode/angularjs/quick-access/

Piwik Upgrade 2.4.0 file permission

I did that but the dropdown menu was “missing” in the Piwik 2.4.0. To fix the problem, I changed the following folders’ permission to 755:

plugins/CoreHome/angularjs/menudropdown/

and these folders:

plugins/SitesManager/templates/directives/
plugins/SitesManager/templates/help/
plugins/SitesManager/templates/sites-list/

All problems solved. My Piwik 2.4.0 looks error free.

[Updated 16-Jul-2014] I just did an upgrade from 2.2.2 to 2.4.1 and applied the same steps as above to resolve the file permission issues.

{ 0 comments… add one }

Leave a Comment